Buy Now
Sign in

Doesn't send email when submitted from certain devices

AlexRees , November 28 2016
A
AlexRees
Over the past few months I've had repeated reports of forms being successfully submitted, but emails not being received. I have only just been able to replicate the issue.

I have a simple contact form with 4 fields. When I submit it on a Windows PC the message sends as expected.

When I submit it using a Google Nexus tablet, the form displays the success message, but an email is never received.

I've had reports of this problem also occurring on Apple devices.

This is 100% reproducible and I am happy to provide admin access etc if it will help.
calculus00
Hello AlexRees,
I'm not a Chrono professional, but after checking your new post, I think that the following links may help:
My form doesn't submit - send emails - save records
P.S: I'm just an automated service
I'm an automated service, my answers may help, but they may not be accurate.
GreyHead
HI AlexRees,

First, I suggest that you add a database table and a DB Save action to the form so that you have a copy saved as a backup.

What are the settings that you are using for your Email? Can you add a Debugger action and copy the debugger output on the tablet and paste it here?

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
A
AlexRees
This is the output. I've used winmerge to compare it with the output when using the form on PC, and they are identical apart from it appears different linebreaks are used.

I've changed the email addresses and blocked out the IP address.

DATA ARRAY:
Array
(
[chronoform] => Contact
[event] => submit
[text1] => Alex
[text2] => alex@myemail.co.uk
[text6] =>
[textarea7] => PD
[button5] => Submit
[ip_address] => xxx.xxx.xxx.xxx
)
Array
(
)


ERRORS:
Array
(
)


DEBUG INFO:
Array 
(
[0] => Array
    (
      [Email] => Array
        (
          [0] => An email with the details below was sent successfully:
          [1] => To:admin@websitedomain.co.uk
          [2] => Subject:Message via websitedomain.co.uk
          [3] => From name:Alex
          [4] => From email:alex@myemail.co.uk
          [5] => CC:
          [6] => BCC:
          [7] => Reply name:Alex
          [8] => Reply email:alex@myemail.co.uk
          [9] => Attachments:
          [10] => Array
            (
            )
            
          [11] => Body:
<table>
<tr><td>Name</td><td>Alex</td></tr>
<tr><td>Email</td><td>alex@myemail.co.uk</td></tr>
<tr><td>Phone</td><td></td></tr>
<tr><td>Message</td><td>PD</td></tr>
</table><br /><br />IP: xxx.xxx.xxx.xxx
        )
        
    )
  
  [1] => Array
    (
      [Email] => Array
        (
          [0] => An email with the details below was sent successfully:
          [1] => To:alex@myemail.co.uk
          [2] => Subject:Thank you for your message
          [3] => From name:Little Wombles
          [4] => From email:admin@websitedomain.co.uk
          [5] => CC:
          [6] => BCC:
          [7] => Reply name:Little Wombles
          [8] => Reply email:admin@websitedomain.co.uk
          [9] => Attachments:
          [10] => Array
            (
            )
            
          [11] => Body:
<div class="form-group gcore-form-row" id="form-row-2"><label for="text1" class="control-label gcore-label-left">Name</label>
<div class="gcore-input gcore-display-table" id="fin-text1">Alex</div></div><div class="form-group gcore-form-row" id="form-row-4"><label for="text2" class="control-label gcore-label-left">Email</label>
<div class="gcore-input gcore-display-table" id="fin-text2">alex@myemail.co.uk</div></div><div class="form-group gcore-form-row" id="form-row-6"><label for="text6" class="control-label gcore-label-left">Phone</label>
<div class="gcore-input gcore-display-table" id="fin-text6"></div></div><div class="form-group gcore-form-row" id="form-row-7"><label for="textarea7" class="control-label gcore-label-left">Message</label>
<div class="gcore-input gcore-display-table" id="fin-textarea7">PD</div></div><div class="form-group gcore-form-row" id="form-row-8"><div class="gcore-input gcore-display-table" id="fin-button5"></div></div><br /><br />IP: xxx.xxx.xxx.xxx
        )
    )
)
A
AlexRees
I've tested with PHP Mail, Sendmail and SMTP. All three emails arrived when the form was submitted from a Windows PC, but nothing arrived when sent via my Nexus.

I was wondering, is it worth me trying the contact form on this site to see if I can reproduce the problem
GreyHead
Hi AlexRees,

As the email is sent from the server - not from the device - it's not obvious why it should send in one case and not in the other.

The one thing that I notice is that the From Email address does not match the domain, that could well cause some emails to be dropped - though not why it would be those from the Nexus.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
C
carbendata
I realize this is an old post but I haven't been able to find any other posts on this subject. I also have a form that allows people to attach pictures and then submits. It works fine, every time, from a PC. However, when someone on an Apple tries (even using the same test pictures I had used from the PC, the form does not send, not does it put an entry into the database. It will either go to a blank screen or in 1 case at least (according to the user & not independently verified) it went to the Thank You screen but didn't send the email and didn't update the database. I am completely at a loss.
GreyHead
HI carbendata,

Please see this FAQ - it was written a while ago for CFv4 but the same code should work with CFv5 if this is your problem.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much