Chronoconnectivity V5 Edit link disappeared

saol89 , November 21 2016
saol89

kind assistance,
in CCv5, when I insert into Front List -> Columns list the value _EDIT_:Edit
the corresponding column is empty (missing link on each row to go to the edit action chronoform)

Attachments
nolink.png
nolink.png
(30.27 KiB)
152 Downloads/Views
admin

Hi saol89,

It used to work before ? or is this a new connection ? what about the permissions setup for the "Edit" action ?

Best regards,
Max

saol89

Hi Max, thank for your reply.

this problem happens only recently, when I create or edit a connection. permissions are all sets to public for every action.

admin

Please send me a link to the list using PM and I will check it!

Best regards,
Max

saol89

I can not let you access the site because of the site's privacy policy (the site contains personal data of many users).

I simply create a new connection, very easy to avoid making errors and the problem remains. I believe that the problem is with the "Core" plugin, because I can not turn it off. Can you give me some possible solution to test?

Thanks Max

admin

Hi saol,

In a new connection you only need to do this:

[list]
[*]fill the connection name
[*]select the table and add a model id
[*]add this to the "columns list" under front listing:

				
Model.id
_EDIT_:Edit

[*]Enable the permissions fort he "index" action, save the connection and test it using the "view connection".
[/list]

It should work with that, if it does not then something is not good and I need to check that.

Best regards,
Max

saol89

nothing new. I write data to access the back-end

Private content
The content here is visible only for authorized users.

admin

Hi Saol,

I tested it, everything is setup correctly but the link is not showing for some reason, I could get the edit link to show using the "Edit linkable" field, so now you can link to the edit page, but neither the _EDIT_ nor the _DELETE_ are working, did you make any changes to any core files ? and is this the latest update ?

Best regards,
Max

saol89

I have not changed any core files. I have already reinstalled CC again and upgraded to the latest version.

How can I reset the Chronoconnectivity core files? It can be a problem CORE plugin that does not activate the _EDIT_ tag? I can restore it in some way?

admin

If you have updated then the files should be okay, I'm not sure what is causing this, but you can use the "Edit linkable" box for now to have your field link to the edit page, this should do exactly the same thing as the _EDIT_ syntax.

If you have enough time before the delivery of this project then you can also contact me again after 2 weeks or so, I may be able to have the next version ready, but I can't be sure of this now.

Best regards,
Max

saol89

Thanks Max, for your reply and for your kindness. I add a reply to this topic in the coming weeks hoping in the meantime you have some news to give me.

Thank you

admin

No problems, but as I noted, the "Edit linkable" box will make any of your fields link to the edit page, which is just as good as the _EDIT_

Best regards,
Max

saol89

I am attaching this log (not sure if it can be useful)

Private content
The content here is visible only for authorized users.

admin

Hi Soal,

Thank you, this is a small glitch in the "backup" function, but it is not related to the edit link issue!!

Best regards,
Max

saol89

hello Max,
do you have any news for me?
I have the same problem on another site, but unfortunately for the moment I can not give you access.

In the meantime you have found a solution?

admin

Hi Soal,

We have Connectivity v6 now, which provides much more flexibility, you can install it on the same site and use it to build this connection only.

Best regards,
Max

saol89

hi Max,
my chronoconnectivity is very complicated and an upgrade to v6 must be programmed, but I would like to run my application now.

Can I ask you the changelog of chronoconnectivity of versions 5.0.13 and 5.0.14?
It can be a problem solved with these updates? I have now stopped at 5.0.12

Thank's
Saol

admin

Hi Saol,

We speak about connectivity here, 5.0.14 is for the forms and will not affect the edit link visibility, I'm not sure honestly what might be causing this, the edit action permissions are allowed for all groups ?

investing a little bit of time with v6 is really worth it on the long run, plus you get much more options and features.

Best regards,
Max

saol89

Sorry, i have 5.0.3 of connectivity, I would like to know the changelog of the latest versions (5.0.4,5.0.5,5.0,6). Certainly when I have solved this problem I will start studying CCv6

Thank's

admin

Hi Saol,

Unfortunately there is no changelog for Connectivity, but there fixes usually included with the update.

I suggest that you update to Connectivity 5.0.6 by installing OVER yours first and test again, I have suggested before that you use the "edit linkable", this is not going to work here ?

Best regards,
Max

Powered by ChronoForums - ChronoEngine.com

ChronoForms Book

The ChronoForms Book, written for ChronoForms v3 contains 350 pages of invaluable ChronoForms How-tos hints and tips.

Note: many of the ideas can be used in ChronoForms v4 but the admin interface is very different and code examples may need to be modified.

SSL

Members Login

 

2CheckOut.com Inc. (Ohio, USA) is an authorized retailer for
goods and services provided by ChronoEngine.com