Buy Now
Sign in

Permalinks and redirect

bleak26 , November 16 2016
B
bleak26
When I do a chrono forms redirect using an event switcher and event loop with perma links set to custom ( http://www.mysite.org/%postname%/ ) it does not work and says "Error 404 no page found" but when I set perma links in wordpress to plain eg: http://www.mysite.org/?p=123 it works fine. Please could you tell me why this is happening and what i can do to resolve it ?

Many thanks
admin
Hi bleak26,

What about the url in the browser's address bar after the redirection ? is it correct ?

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
C
cham
Yes the URL in the address bar looks correct
admin
can you post a link for testing ? you can add it inside the private tag if you don't want it to be public.

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
C
cham
The content here is visible only for authorized users.
admin
Hi,

The problem is that it's not possible to directly redirect inside a WP plugin as easy as its in Joomla, and it may not work all the time, I suggest that you display a thanks message after form submit and use JS code to redirect the page after 1 second (or whatever), just use this code in a "Load js" action in the "on submit" event:

setTimeout(function () {
window.location.href= 'http://www.google.com'; // the redirect goes here
},5000);


5000 = 5 seconds.

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!