Buy Now
Sign in

chronoengine_extensions' doesn't exist SQL=DESCRIBE `#__chronoengine_extensions`

reficedev , July 18 2016
r
reficedev

I installed the last chronoform, but when I try to go to /administrator/index.php?option=com_chronoforms5 it says :

Table 'sitename.#__chronoengine_extensions' doesn't exist SQL=DESCRIBE `#__chronoengine_extensions`

I tried this http://www.chronoengine.com/forums/posts/f3/t99808/database-table-not-found-after-installing-component.html but It made no change for me.

Do you know what's going on ? It's not the first time I install your great plugin, but I never seen this.

GreyHead

Hi reficedev,

Does the table exist in the database now? Were you able to CREATE is successfully?

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

r
reficedev

I can see 2 tables :

mmp_sc536_chronoforms
wich is not empty

also I have a mmp_sc536__chronoengine_chronoforms table

GreyHead

Hi recifedev,

Then it looks as if you still need to create the mmp_sc536__chronoengine_extensions table ??

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

r
reficedev

Sorry I dont understand

GreyHead

Hi recifedev,

Sorry, finger problems - you need to create the mmp_sc536__chronoengine_extensions table

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

r
reficedev

it's already created

				-- phpMyAdmin SQL Dump


SET SQL_MODE = "NO_AUTO_VALUE_ON_ZERO";
SET time_zone = "+00:00";


/*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
/*!40101 SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */;
/*!40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION */;
/*!40101 SET NAMES utf8 */;

--
-- Base de données : `shopcoiffure_d`
--

-- --------------------------------------------------------

--
-- Structure de la table `mmp_sc536__chronoengine_chronoforms`
--

CREATE TABLE IF NOT EXISTS `mmp_sc536__chronoengine_chronoforms` (
`id` int(11) NOT NULL,
`title` varchar(255) NOT NULL DEFAULT '',
`params` text NOT NULL,
`extras` longtext NOT NULL,
`published` tinyint(1) NOT NULL DEFAULT '1',
`app` varchar(255) NOT NULL DEFAULT '',
`form_type` int(1) NOT NULL DEFAULT '1',
`content` longtext NOT NULL
) ENGINE=InnoDB DEFAULT CHARSET=utf8;

--
-- Index pour les tables exportées
--

--
-- Index pour la table `mmp_sc536__chronoengine_chronoforms`
--
ALTER TABLE `mmp_sc536__chronoengine_chronoforms`
ADD PRIMARY KEY (`id`);

--
-- AUTO_INCREMENT pour les tables exportées
--

--
-- AUTO_INCREMENT pour la table `mmp_sc536__chronoengine_chronoforms`
--
ALTER TABLE `mmp_sc536__chronoengine_chronoforms`
MODIFY `id` int(11) NOT NULL AUTO_INCREMENT;
/*!40101 SET CHARACTER_SET_CLIENT=@OLD_CHARACTER_SET_CLIENT */;
/*!40101 SET CHARACTER_SET_RESULTS=@OLD_CHARACTER_SET_RESULTS */;
/*!40101 SET COLLATION_CONNECTION=@OLD_COLLATION_CONNECTION */;

GreyHead

HI recifedev,

There's nothing there about the chrono_extensions table . . . does that exist - you are getting an error message saying that it doesn't.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

r
reficedev

so I tried to add the table manually on more time :

				--
-- Table structure for table `#__chronoengine_extensions`
--

CREATE TABLE IF NOT EXISTS `#__chronoengine_extensions` (
`id` int(11) NOT NULL AUTO_INCREMENT,
`addon_id` int(11) NOT NULL,
`name` varchar(255) NOT NULL,
`title` varchar(255) NOT NULL,
`enabled` tinyint(1) NOT NULL,
`ordering` int(4) NOT NULL,
`settings` text NOT NULL,
PRIMARY KEY (`id`),
KEY `name` (`name`)
) DEFAULT CHARSET=utf8;

-- --------------------------------------------------------

--
-- Table structure for table `#__chronoengine_forms`
--

CREATE TABLE IF NOT EXISTS `#__chronoengine_chronoforms` (
`id` int(11) NOT NULL AUTO_INCREMENT,
`title` varchar(255) NOT NULL DEFAULT '',
`params` text NOT NULL,
`extras` longtext NOT NULL,
`published` tinyint(1) NOT NULL DEFAULT '1',
`app` varchar(255) NOT NULL DEFAULT '',
`form_type` int(1) NOT NULL DEFAULT '1',
`content` longtext NOT NULL,
PRIMARY KEY (`id`)
) DEFAULT CHARSET=utf8;


today it is working, thank you