Buy Now
Sign in

Recaptcha error Chronoforms V5 Module

yusufo , June 22 2016
Y
yusufo
Hi,

I have on my site two chronoforms v5 forms. A contact form that is working great with google no captcha and another form to submit a CV to our database and send it by mail.

When I fill the form with the option "Test form" of Chronoforms Admin Panel, I am able to submit the form without any errors.

When I try to submit a form that uses Chronoforms v5 Module, it shows this error:

" The reCAPTCHA wasn't entered correctly. Please try it again.


Notice: Undefined index: error-codes in /var/www/vhosts/inhiset.com/httpdocs/administrator/components/com_chronoforms5/chronoforms/actions/check_nocaptcha/check_nocaptcha.php on line 35"

I have PHP 5.6.22 on my server.

Thanks. Regards,

Joaquín
GreyHead
Hi Joaquín,

This should work correctly - please post a link to the form so I can take a quick look.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
Y
GreyHead
Hi Joaquín,

It looks as though the form is submitting correctly but the Google NoCaptcha check is failing - and the PHP Notice suggests that there is no response from Google, not that the code sent is incorrect . By all means PM me the site URL, the form name, and a SuperAdmin login and I'll take a quick look and see if I can add some debug code to see exactly what is happening.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
GreyHead
Hi Joaquín,

I can't work this out - it looks to me as if the form is 'looping' and being submitted twice, the first time the Google check is passed, the DB Save and email run correctly; the second time the Google check fails and the form is re-loaded. I suspect that this is a result of the SEF URL that is being used to re-load the form at with the message at the end.

The simplest fix is probably to redirect to a different Thank you page - I've added a ReDirect that goes to a 404 message at the moment.

You could also add a check in the On Load event to see if this is a re-load and not show the form in that case.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
U
underground1
Hi, GreyHead,

I have a similar problem - Recaptcha doesn't want to validate ...
I have rechecked the keys and checked the settings against other pages where the form works problem with no success. The only difference here is that I need to use a module ...

If you could help me, I would greatly appreciate it.

The page is http://www.slikopleskarstvo-camigo.si/
Attachments
camigo_form.jpg
camigo_form.jpg
(444.67 KiB)
921 Downloads/Views
GreyHead
Hi underground1,

The first thing to try please is to replace the Check ReCaptcha action with a Check Google NoCaptcha action.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
U
underground1
Of course ...
Thanks. It works as it should.
S
Sniecinski
Hi GreyHead,

I have a problem with validate Google NoCaptcha - each time it is unsuccessful. Forms to work for a few months and validation worked well. Recently stopped working, for some unknown reason. I have several forms on a page and each doesn't work. I set no major changes to the site, only the most current updates and added ssl certificate. Could you look at my website and see what might be causing the problem, please?
https://www.hkl.pl Joomla verson 3.6, Chronoforms 5.0.11
Forms: https://www.hkl.pl/kontakt, https://www.hkl.pl/zapytanie, https://www.hkl.pl/maszyna-uzywana


Kind Regards,
Lukas
GreyHead
Hi Sniecinski,

I'm not sure what is happening. There are some problems with the https setup - the form is not using https to submit and there are a number of errors because files are being requested using http. This may be a problem with the livesite setting in the site configuration.

I suggest that the first thing to do is to sort this out and see if that clears up the NoCaptcha problem. Otherwise I suggest that you double-check the key settings and make sure that the https domain is registered with Google.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
S
Sniecinski
Thank you for your answer. I checked the keys, are OK. What do you mean by "make sure that the https domain is registered with Google"? In captcha settings in google accounts are the same domain without http or https.
GreyHead
Hi Sniecinski,

I may well have been wrong about that, sorry. I was trying to think of reasons why the ReCaptcha might be failing.

By all means PM me the site URL, the form name, and a SuperAdmin login and I'll take a quick look.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
M
mmaack
Same issue here. The nocapture shows up on the test form. but not when the form is delivered in a module. I have the Google NoCaptcha working on 2 forms. The one giving me fits is a second form on a page that functions separate of the other form.

Changing to recaptcha works, but the recaptcha image is messed up. Codes match, deleted and recreated the elements, but no joy.

The content here is visible only for authorized users.


Mark
GreyHead
Hi Mark,

It is probably possible to have two ReCaptchas on the same page - see the Google Docs here and these My Codde suggestions. The problem is that I can't immediately see how to get this to work with a form in a module that might appear on many pages. (It probably can be done with some careful thought and planning.)

A simpler solution is not to have two ReCaptchas on the same page but to replace one with a different captcha - I favour the HoneyPot as that is invisible to the user.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
S
Stush
Anyone else had any luck with this? I've run into the same problem and it's driving me nuts, i've tried reinstalling chronoforms, deleted the forms and started over, the form submits fine, but you just get this error message.

Thanks for your help.
Attachments
Screen Shot 2016-11-22 at 11.17.48 AM.png
Screen Shot 2016-11-22 at 11.17.48 AM.png
(33.71 KiB)
629 Downloads/Views
GreyHead
Hi Stush,

I've seen this happen when file_get_contents() is disabled in the Server settings. You might check the System Info > PHP Info tab to check that. I do have a modified version of the Check ReCaptcha action that will use cURL if that is available, or file_get_contents() if not.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
S
Stush
The weird thing there is that we use a basebuild for our sites, we don't really change any of the PHP settings, and chronoforms is working fine on so many other sites.

Would I be able to grab that modified action to give it a shot?
S
Stush
Okay, I think i've solved the problem, it wasn't a chronoforms issue, it was an issue with the way the form was put there. I used Regular Labs modules anywhere to place it, but I did it a different way than usual, using the ID rather than a modulepos, and this was causing the issue, I changed it and it's working fine.

Thanks so much for your help, though, you do amazing work.