Buy Now
Sign in

Email Address Confusion

Chris..S , July 08 2008
C
Chris..S 6
July 08 2008 #10159
The form configuration page accepts email addresses in "name-addr" format, e.g. "my name" <my.name@somedomain.com>, but it does not echo this format back correctly. A subsequent update of the form configuration will fail unless the email address(es) are re-entered.
C
Chris..S 6
July 10 2008 #10223
The solution is to wrap all the email input values in htmlspecialchars(). Actually, all type="text" input fields should do this unless your validation either strips special characters or refuses to echo data that contains them.
GreyHead 63.4
July 11 2008 #10240
Hi Chris,

Neat workaround. Provided that you use the JRequest calls, Joomla does provide some input filtering.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
C
Chris..S 6
July 11 2008 #10243
Actually, I should have said, to wrap the "echoing" of all ...

I'm not sure about the JRequest calls. Some of the admin setting fields are currently being echoed back with htmlspecialchars, I just followed that convention.