Buy Now
Sign in

CCv5 pagination

bcouvin , January 15 2016
b
bcouvin

Hello,

I have a problem with pagination. I have 3 listings in 3 web pages.

The first one is set by default to 30 (standard value).
The second one don't have pagination (PAGINATION_NAV, _PAGINATOR_LIST_ nor PAGINATOR_INFO_)
The third one is set to page limit to 8 in FrontList/Settings/page limit.

When I set at front end the first listing limit to 5, I see the second listing is limited automatically to 5, without any paginator....I can not select other rows higher than 5.

The 3rd page is limited like the second page (limited to 5 rows), while the initial setting on BackEnd was set to 8.
I log out and log in again with clearing all caches and cookies. It is not working too.

Please give a a help,....

Thanks in advance.
Bertrand

b
bcouvin

Hello,
Does anyone have an idea on this?
Bertrand

MainsailSoftware

I am having a very similar issue. The Page Limit setting does not work!

If you add the dropdown (_PAGINATOR_LIST_) then the listing limit works according to what the dropdown is set to.

I do not want my users to have access to the dropdown and want to have a preset of 20 lines on the front-end for a specific list.

Additionally, if I use the limit dropdown in the front-end, have it set the value to 20, and then removed the dropdown via back-end admin edits to the Connection and refresh the front-end page, it stays at 20. This suggests something in session and/or cookies.

But If I logout from the front-end and the back-end, clear all cookies, it will keep the 20 on the front-end after I log back in.

Additionally, if I Request::set(limit, 20) to a value just prior to setting up conditions in the main model, that works, but effects both the front-end and back-end, along with causing all listings in the front-end not specific to the Connection to now use the 20 line limit.

The setting for Page Limit within the Connection editor is not working!

And I cannot a way to programmatically set it for a specific Connection, and cannot figure out where this value is being set. I have even tried Global Configuration | Default List Limit set to 20 and it seems to be totally ignored too.

Using the _PAGINATOR_LIST_ dropdown is not a solution.

Mbiyc Webmaster
President, Sr. Software Architect, Mainsail Software LLC

GreyHead

HI,

Please ask Max using the Contact Us menu above and linking to this thread.

I'm not familiar enough with the CC code to do anything more than you have already tried.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

admin

Hi,

Please check the "Help" tab, use this code in the header box to display the navigation links only:

				<?php echo $this->view->Paginator->getNav(); ?>
				


And use the "Page limit" setting to control the max number of rows per page.

Regards,
Max

Max
If your main question got answered then please mark the answer using the button!

b
bcouvin

Hello Max,

Thank you for your reply.
I only used your proposal since my first post.

We (me and MainsailSoftware) are talking about (_PAGINATOR_LIST_ OR $this->view->Paginator->getList();). This feature is not compatible with the "Page Limit" setup value.
So we can not use this feature.

My question is to know if we would have a solution to make this works.

Regards
Bertrand

admin

Ok, please test the "Page limit" on a single connection page, using the "view connection" link, set the page limit to "10" for example, then login/out on the frontend a couple of times, what's the list limit ? does it work as expected ?

Max
If your main question got answered then please mark the answer using the button!

k
kate_ee

WHY can't set the "page limit" to ALL ? how to set the default value in one step ?
I don't want 30, I want ALL .
Any fixed in this issue ?
Please help !

CAN YOU SIMPLY LET US CHANGE THE DEFAULT VALUE ?

admin

Hi kate_ee,

You can set it to a high value to cover all the results like 100 or use v6 which has the feature you need.

Best regards,
Max

Max
If your main question got answered then please mark the answer using the button!

k
kate_ee

thank you very much for your promptly reply.
I set the "Page Limit" to 100 , but I don't really know how big the result set is. And I want to hide that "Page Limit" to the user. Just simply showed them all they looked for/

If I use v6, should I rebuild all the stuff in v6?

thank you in advance

admin

Hi kate_ee,

Loading too much results in 1 page is not a good idea and will increase the server load, I suggest using 100 as the limit and hide the limit selector using css.

If you use v6 then you will have to build the connection again, but v6 is new and has more control and features, there is a tutorial in the FAQs section.

Best regards,
Max

Max
If your main question got answered then please mark the answer using the button!

k
kate_ee

I agree that loading all the result everytime will increase the server loading. But the users want to check all the records they have input, and don't aware the LIMIT.

And, I notice that there is NO next page button or link to let the use know there are more records in next page.

Rebuild the connections is a painful job.... T_T
thank you very much for your reply

admin

Hi kate,

If there are no next page buttons then you didn't add the paginator string in order to show it.

If you decide to try v6, then it can work with v5 on the same website, so you may use it to build something specific.

Best regards,
Max

Max
If your main question got answered then please mark the answer using the button!

k
kate_ee

Hi Max,

I finally can add the _PAGINATOR_NAV_ in my page, it is amazing !
Thanks a lot , I will shift my stuff to new version when I have enough time.
Thank you very much for your help !


Kate