Sat Dec 20, 2014, 9:39 am
 Locked  9  3076
Showing 1 to 10 of 10 entries.

Hi, I have similar problems as several others in that I cannot save my forms in admin, tried all solutions with no luck, If I click on either save, save and close or close, joomla admin goes into a neverending loop and I have to click on some other menu to stop the loop.

I solved that by doing my changes in the database for now, but that is not a really good solution though.

I also cannot send email or submit my form at the site, whenever i try that I get following error;

"Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 40961 bytes) in /**/**/**/**/**/**/components/com_chronoforms/libraries/chronoform.php on line 248"

14 0
Thu Apr 9, 2009, 2:02 pm

Hi yaxo,

The out of memory error suggests that you may have an Event Loop action that is pointing to the event that it is in so it gets in a loop.

Although the Event Loop is partly broken in the current release it still redirects to the On Load event and so probably shouldn't be used there.

Bob


ChronoForms technical support

If you'd like to buy me a coffee, thank you very much

Moderator
38213 42028
Tue May 29, 2007, 6:15 pm

Ah, thank you, the event loop pointed to nothing and there is nothing to choose, had to remove it from the database and now I can send mail and submit the form, but still not save from the admin, I guess there are remains in the form about the event loop.

But I still need some way to verify that all fields are filled in and the form not being sent if all fields aren't correctly filled up.

Are there other alternatives for that or should I perhaps downgrade to some version before the latest for that?

//Anna

14 0
Thu Apr 9, 2009, 2:02 pm

Hi Anna,

The Event Loop doesn't explain the Admin side problems. That sounds more like a problem with server security. If suhosin is running then these three settings need to be at least 1,000 (possibly 2,000 if you use large forms).

suhosin.get.max_vars

suhosin.post.max_vars

suhosin.request.max_vars

The Event Loop default settings are OK 95% of the time and you can still use it in the On Submit event.

Bob


ChronoForms technical support

If you'd like to buy me a coffee, thank you very much

Moderator
38213 42028
Tue May 29, 2007, 6:15 pm

Suhosin doesn't seem to be installed at the server.

I tried to add an event loop to a new form also, I cannot choose any event for it, it is just blank even though it should find events. I cannot either save the form when I added it anyway.

Now there is work all week, but I will try to find some time to look at this more

//Anna

14 0
Thu Apr 9, 2009, 2:02 pm

Hi Anna,

OK - hopefully Max aill have a new release with a fix for the Event Loop bug soon.

Bob


ChronoForms technical support

If you'd like to buy me a coffee, thank you very much

Moderator
38213 42028
Tue May 29, 2007, 6:15 pm

Now I tried to install latest joomla in the 1.5 series and set up a v4 form there, now I can save the form wizard "sometimes" but mostly not, Yesterday I also got verification working in the form and emails are sent out without problem and the form is submitted.

Today emails are sent out without problems, but the verification is gone, it is possible to submit the form without nothing and I still cannot save the form when editing in the wizard. No event loops are added to this form, and when I added the events, I saved after every event to see where and if it went bad, everything was ok and I was happy, until I wanted to edit a text in a header field, then the saving in the form wizard stopped working again, and I'm back in an neverending loop.

But I tried use this "run updater", and no database fields where updated without problem, and then I could at save the form in the form wizard again, one time, now I cannot replicate that and the loop is back. The problem persist on three different servers also

For changing of the fields I can live with having to do that in the database for now, but it is quite annoying that I cannot get verification to run and that peole can submit empty forms.

But on the other hand, I am halfway there, I can send emails now :)

But is there anyone who can help me solve this verification problem?

//Anna

14 0
Thu Apr 9, 2009, 2:02 pm

Hi Anna,

There was a bug with the Event Loops in CFv4 RC3.1 and 3.11. This has now been fixed in RC3.2 Please upgrade and see if this resolves your problem.

Bob


ChronoForms technical support

If you'd like to buy me a coffee, thank you very much

Moderator
38213 42028
Tue May 29, 2007, 6:15 pm

Already upgraded and hoped that it had solved my problems, when that did not solve my problems I did this try with version 1.5.25 of joomla...

//Anna

14 0
Thu Apr 9, 2009, 2:02 pm

It appears to be a bug from IE browser.....

Please use Firefox.... I was able to change and save setting for SMTP and now my mail works fine ;)

1 0
Fri Mar 23, 2012, 3:43 pm
Showing 1 to 10 of 10 entries.

Powered by ChronoForums - ChronoEngine.com

ChronoForms Book

The ChronoForms Book, written for ChronoForms v3 contains 350 pages of invaluable ChronoForms How-tos hints and tips.

Note: many of the ideas can be used in ChronoForms v4 but the admin interface is very different and code examples may need to be modified.

SSL

Members Login

 

2CheckOut.com Inc. (Ohio, USA) is an authorized retailer for
goods and services provided by ChronoEngine.com