Error message after pushing the submit button

syco , February 17 2012
s
syco

Hi Guys,

I'm getting the following error message at the top of the page which I would like to fix... and even if I have the "Show Top Errors" set to NO, it still shows this error message.

Notice: Undefined offset: 0 in /clientdata/zeus-dynamic-1/b/e/bestpricenissan.com.au/www/libraries/joomla/utilities/utility.php on line 67

Notice: Undefined index: in /clientdata/zeus-dynamic-1/b/e/bestpricenissan.com.au/www/administrator/components/com_chronoforms/form_actions/email/email.php on line 66



Any suggestions? As the site is now LIVE... and the everything seems to work... accept this error message that pops up. :(

The URL is: http://www.bestpricenissan.com.au

In the Backend of the site... I also get the following message in GREEN above the form that is created.

Your Chronoforms install at Notice: Undefined variable: domain in /clientdata/zeus-dynamic-1/b/e/bestpricenissan.com.au/www/administrator/components/com_chronoforms/views/index.php on line 38
is Validated



Cheers,

Syco

GreyHead

Hi syco,

Technically they aren't 'Error' messages they are PHP Notices intended to let developers know of possible problems.

If you set Site Error Reporting to System Default or to None in the Site Global Configuration they should disappear.

Bob

s
syco

Hi Grey,

You said:

If you set Site Error Reporting to System Default or to None in the Site Global Configuration they should disappear.



I had already checked this and I have double checked this and it is set to 'none'.. but unfortunately I still get the error messages. :(

Would you like to login to the back-end and check this or ftp details... or do you have any other suggestions.

Regards,

Syco

GreyHead

Hi syco,

Ther your server isn't allowing Joomla to make the PHP settings. You can probably do this by editing your php.ini file. Having Warnigns and Notices displayed is useful for a development site; you really don't want it for a production site.

The first two messages relate to emails setting- either the From or Reply To values. Plese check those.

The admin warning is odder. The value of domain is quite clearly defined in the code that I am looking at.

You might want to upgrade to the latest version of ChronoForms to see if that makes any difference.

Bob

s
syco

HI Grey .. once again thanks for the quick reply !!
I updated to the latest version which got rid of one of the Error messages... but the following one still remains:

Notice: Undefined offset: 0 in /clientdata/zeus-dynamic-1/b/e/bestpricenissan.com.au/www/libraries/joomla/utilities/utility.php on line 67



You said:

The first two messages relate to emails setting- either the From or Reply To values. Plese check those.


I'm not quiet sure what I need to check as they forms all working correctly... :?:

Only problem is the displaying of this message once the submit buttons had been pushed :(
Would you like me to create an admin account so you can login in and have a look.. I could PM the details if you would like to do this.

Cheers,

Michael

GreyHead

Hi syco,

Back to the php.ini file I think.

Bob

s
syco

Hi Grey,

Where do I find this file... as I don't have this file in the root directory.

Look forward to your reply.

Cheers,
Syco

GreyHead

Hi Syco,

It is php.ini (not php,ini as I typed). It will be on your server somewhere and is the PHP configuraton file (nothing much to do with Joomla! or ChronoForms). YOu can see the main settings in your site System Info section, that may also tell you where the file is located.

Bob

s
syco

Well Grey... I'm still baffled and no closer to fixing this as it is doing the same thing on a new site I am building after I have filled out a form. http://www.test-swishimage.au.com/taxico

I have once again tried to find this 'php.ini' file you mention... but still can't locate it anywhere.
I tried looking at the following file that is listed in the error message

Notice: Undefined offset: 0 in /clientdata/clients/t/e/test-swishimage.au.com/www/taxico/libraries/joomla/utilities/utility.php on line 67


This is the line of code on line67 of the file.
				$mail->addReplyTo( array($replyto[$i], $replytoname[$i]) );
				

You said:

It will be on your server somewhere and is the PHP configuraton file


There is an file named - configuration.php in the root directory... but that is not what I thought you said I had to find... I thought you said locate - php.ini is the configuration.php the same thing?

Also.. if I can actually eventually locate this... then what do Actually will I need to do to the file.
PS> I have set Site Error Reporting to System Default or to None in the Site Global Configuration, but this has not made it disappear.

Would you like me to PM--- ftp details so you can have a look?

Look forward to your response :)
Regards,
Syco

GreyHead

Hi syco,

The PHP.ini configures the way that you have PHP set up on your server, it isn't in your Joomla! folders. You web host help files should tell you where it is and how to configure it. Thanks for the login offer but I don't touch other people's server configuratons.

Bob

s
syco

Hi Bob,

I have got it to stop displaying the php errors by adding the following code as the top of the index.php file in the root directory. ( Straight after the <?php )

				error_reporting(0);
				


I couldn't seem to get the php.ini file to work.
Do you think there will be and problems by doing what I have done... as it has stopped the message form coming up?

Regards,

Syco

GreyHead

Hi syco,

I think that should be OK.

Bob

Powered by ChronoForums - ChronoEngine.com

ChronoForms Book

The ChronoForms Book, written for ChronoForms v3 contains 350 pages of invaluable ChronoForms How-tos hints and tips.

Note: many of the ideas can be used in ChronoForms v4 but the admin interface is very different and code examples may need to be modified.

SSL

Members Login

 

2CheckOut.com Inc. (Ohio, USA) is an authorized retailer for
goods and services provided by ChronoEngine.com